PHPBuilder - WordPress and PHP 5: Be the Change You Want To See



RSS Twitter
News News Reviews

WordPress and PHP 5: Be the Change You Want To See

by: Scott Clark
|
November 19, 2009

The other day, I wrote the popular 10 Things You Need to Know About WordPress 2.9. As usual, most people are very excited about the new release which is now in beta and available for testing. In the article, I made a few fundamental errors which I have since corrected.

Notably, I mentioned that WordPress 3.0 would be going to PHP 5. This was based on conversations I had with a core developer which I now realized I misunderstood. Kinda. WordPress will probably not be dropping PHP 4 support in WordPress 3.0 but as core developer Mark Jaquith suggests:

Some things already require PHP 5, like time zone support or oEmbed. There are no plans that I know of to remove PHP 4 support in 3.0 last I checked we still had 12% of WP installs using PHP 4.

I see more of a natural and gradual deprecation of PHP 4. Were very much open to making new features require PHP 5 if it would be a pain to make them PHP 4 compatible.

As a PHP developer, I am on board with calls for PHP 5 support. PHP 4 has been end of life (EOL) since August 8, 2008. That basically means that there will be no more releases, no more security patches, no more nothing. Its done. Stick a fork in it. However, as Matt mentioned on stage at WordCamp NYC this weekend, there are still 12% of WordPress installations using PHP 4 hosting. He breaks that down as approximately 2M installs, the size of a major American city. More precisely, thats approximately the size of Philadelphia.

Read the whole story at http://technosailor.com/2009/11/18/wordpress-and-php-5-be-the-change-you-want-to-see/

Comment and Contribute

Your comment has been submitted and is pending approval.

Author:
Scott Clark

Comment:



Comment:

(Maximum characters: 1200). You have characters left.